I've been using Vista as my main OS now for an entire week, and things have been somewhat better than what I expected. No crashes so far, and almost all seems to work just fine. A few things things I've noticed:

  • Coming out of hibernate feels a bit faster than on XP, which is good.
  • Putting the machine on hibernate, however, feels a lot slower than on XP (almost twice as long, in fact). It does not help that the screen just goes blank while entering hibernation and there's no progress bar like in XP. I wonder if this has something to do with the fact that I used to run XP without a paging file (though I don't see why this should matter).
  • Most applications I've installed so far seem to be working fine in general terms, and once you get past the initial installation spree, UAC isn't so bothersome as I expected. That said, I still thing UAC isn't quite the solution to the original problems (the whole administrator that can't do everything but doesn't need to prove anything to get elevated privileges things just doesn't seem right to me).
  • Speaking of UAC, why the heck can I do "ipconfig /renew" as a normal user but doing " ipconfig /release" requires elevation? Makes no sense at all to me.
  • Installed PrimoPDF, which I used all the time in XP to print to a PDF file. Seems to install fine on Vista, and even run; but it generates 0-bytes-length files. Haven't had the time yet to check what exactly is going on here. I also usually install the Microsoft XPS and PDF Save-As AddIn for Office 2007, like Scott mentions here, which does work fine (but it's only useful in office, unlike PrimoPDF).
Technorati tags:


Tomas Restrepo

Software developer located in Colombia. Sr. PFE at Microsoft.